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Product Description

Design and simulate RF systems

SimRF™ provides a component library and simulation engine for designing
RF systems. It includes mixers, amplifiers, S-parameter blocks, and other
basic blocks for architectural design and modeling of wireless transceivers.
You can connect these components arbitrarily to form diverse architectures
and to model system-level impairments. SimRF enables simulation of

RF gain, noise, and intermodulation distortion commonly attributed to

RF amplifiers. It provides circuit envelope technology for simulating RF
impairments uniquely associated with mixers, including image rejection,
reciprocal mixing, local oscillator phase offsets, DC conversion, and DC
offsets. Equivalent baseband technology is also included, enabling fast
simulation of single-carrier cascaded systems.

Key Features

e Multiple carrier-frequency models
¢ General N-port models and S-parameter data files

® Passive components, including resistors, capacitors, inductors, and general
impedance blocks

¢ Weakly nonlinear 3-port mixers and 2-port amplifiers specified by noise
figure, IP2, IP3, and data files

® Intra-model signal probing
¢ (Circuit envelop technology for high-fidelity simulation

e Equivalent baseband technology for fast simulation
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Minimize Computations for RF Simulations

In this section...

“Simulate a Passband Signal in Simulink Software” on page 1-4

“Compare Passband and Baseband Signals in SimRF Software” on page 1-6

“Simulate the Envelope of a Baseband Signal” on page 1-9

This example shows how to use circuit-envelope simulation to reduce the
number of time steps required to simulate a simple signal by a factor of 100.

Traditional methods of circuit simulation are not ideal for RF systems. In
Simulink®, simulating signals with high-frequency components requires
choosing a proportionately small time step. However, the envelope of such
signals often varies on a much larger time scale. The SimRF circuit-envelope
environment takes advantage of this condition in order to model RF signals
accurately, while also reducing simulation time.

The following figure illustrates a signal x(¢) for which circuit-envelope
simulation is ideal:

X

() = Altlcos|2xf.t)

b Al A

LLLL
| 'I..I'J ||.IIII || 1 I-,'., || ] -ul' |
L]

SR | LD L | L

!

1

The signal consists of a time-varying modulating signal on a high-frequency
carrier. In many RF applications, the frequency of the modulating signal A(t)
is much less than the frequency of the carrier, f,.

SimRF software handles the carrier cos(2mf,t) analytically, so it only needs
to simulate the modulating signal. The redefined system that the software
uses 1s mathematically equivalent to the original. However, by taking time
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steps on the scale of the modulating signal instead of the carrier, the software

produces equivalent results in less time.

Simulate a Passband Signal in Simulink Software

The model

ex_simrf_tut_passband

simulates a 1-GHz sine wave using fundamental Simulink blocks. This

section of the example shows you how to modulate a real passband signal with

in-phase and quadrature components.

E| ex_simtf_tut_passband
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The system specifies a real passband signal x(f) according to the formula

x(t) = I(t)cos (2 f,t) - Qt)sin (27 f,t)

where:
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® J(¢) 1s the in-phase part of the modulating signal, equal to 3 in this example,
modeled by the Constant block labeled In-phase modulation.

® @(t) is the quadrature part of the modulating, equal to 4 in this example,
modeled by the Constant block labeled Quadrature modulation.

® f.is the carrier frequency, equal to 1 GHz in this example.

Running the model produces the following output on the scope.

u Real Passband Scope E'@ ﬁ
SEPLY aEB 2ASRE -

P

The output signal at the Real Passband Scope has a magnitude of 5 and a
phase shift of atan2d (3, -4), or about 143°.

In the Configuration Parameters dialog box, the Fixed-step size
(fundamental sample time) parameter has been set to 1/20*1e-9. This
value is on the order of the wavelength of the carrier. The simulation takes a
total of 101 samples—20 per cycle.
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Compare Passband and Baseband Signals in SimRF
Software
The model

ex_simrf_tut_compare

simulates a 1-GHz sine wave using SimRF blocks. This example builds on
the results of the previous section, “Simulate a Passband Signal in Simulink
Software” on page 1-4.

17] ex_simrf_tut_compare EI@
File Edit View Simulation Format Tools Help
= = = S |5&-5' | Normal |

r

! g
344 L RF RF

Q

Y

Complex medulaticn X .
SimRF SimRF Cutporti I/ Scope

Inport

RF 5L =|:|

Real Passband Scope

=0

SimRF Outport

Solver

Configuration RE SimRF
FParameters

Ready 100% FixedStepDiscrete

The system simulates a real passband signal as the real part of a complex
passband signal according to the formula

x(t) = Re[ (I(t) + jQ®))exp(j - 2nf,t) | = I®) cos(2n f.t) - Q@)sin (2n f, )

where:

® J(t) + jQ(?) is the complex-valued modulation, equal to 3 + 4;.
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¢ f.is the angular frequency, equal to 1 GHz.

Contrary to the Simulink passband implementation in the previous section,
the complex baseband signal driving the SimRF system does not include the
carrier. Instead, the SimRF environment handles the carrier analytically.
The carrier appears in four different blocks in the SimRF environment:

¢ In the SiImRF Inport block, the Carrier frequencies parameter defines
the carrier frequencies of the modulations entering from outside the SimRF
environment. In this example, there is only one input signal, and only one
carrier (1 GHz, specified as 1e9 Hz).

® In the SimRF Outport block, the Carrier frequencies parameter specifies
the signal on the 1e9 Hz carrier (1 GHz) as Simulink signals. These
signals appear at the I and Q ports. The Output parameter is set to Real
Passband, so this signal represents a real passband signal on the 1-GHz
carrier.

¢ In the block labeled SimRF Outportl block, also a StmRF Outport block,
the Carrier frequencies parameter specifies the signal outputted on the
1e9 Hz carrier (1 GHz) as Simulink signals. These signals appear at the I
and Q ports. The Output parameter is set to In-phase and Quadrature
Baseband, so these signals represent the in-phase and quadrature
modulations of the signal on the 1-GHz carrier.

¢ In the SimRF Parameters block, the Carrier frequencies parameter
specifies all of the carriers to be modeled in the SimRF circuit-envelope
simulation environment. In this example, only one carrier is specified.

Note The Solver Configuration block, required in SimRF models, retains its
default settings.

Running the model produces the following output on the scopes.

1-7
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P

n Real Passband Scope E'@ ﬁ
SEPLPLrr aAERB AR -~

The Real Passband Scope displays the same output as the example in the
previous section, “Simulate a Passband Signal in Simulink Software” on page
1-4. The signal has a magnitude of 5 and a phase shift consistent with the
specified in-phase and quadrature amplitudes.
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|n-phase modulation

Huadrature modulation

The 1-GHz carrier itself does not appear in the output. The results correspond
to the real and imaginary parts of the Complex modulation at the input of the
system. They also correspond to the In-phase modulation and Quadrature
modulation blocks in “Simulate a Passband Signal in Simulink Software”

on page 1-4.

In the Configuration Parameters dialog box, the Fixed-step size
(fundamental sample time) parameter has been set to 1/20*1e-9. This
value is on the order of the wavelength of the carrier. The simulation takes a
total of 101 samples—20 per cycle.

Simulate the Envelope of a Baseband Signal

The model

ex_simrf_tut_envelope

simulates the envelope of a 1-GHz sine wave using SImRF blocks. This
example builds on the results of the previous section, “Compare Passband and
Baseband Signals in SimRF Software” on page 1-6.



1 Introduction to Circuit Envelope Simulation

17] ex_simrf_tut_envelope EI@
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The system is almost identical to the system in the previous section, except:

¢ The model contains only one SimRF Outport block and only one scope. The
SimRF environment outputs in-phase and quadrature modulations of the
1-GHz signal. In the SimRF Outport block, the Output parameter is set to
In-phase and quadrature baseband. Since the system is not configured
to output a real passband signal, the carrier is not simulated.

¢ In the Configuration Parameters dialog box, the Fixed-step size
(fundamental sample time) parameter is greater. Its value is 5e-9
instead of 1/20*1e-9.

Running the model produces the following output at the scope.
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The I/Q Scope displays the in-phase and quadrature baseband components of
the 1-GHz signal. The 1-GHz carrier itself does not appear in the output. The
results correspond to the real and imaginary parts of the Complex modulation
at the input of the system.

In contrast to the models in the previous two sections, Simulink works
differently in this model. Because the modulating signals are constant in this
example, only two sample points are needed. To simulate a time-varying
modulating signal, Simulink can use a fixed time step on the order of the
reciprocal of its bandwidth.

The model uses a value of 5e-9 for the Fixed-step size (fundamental
sample time) parameter. This value equals the Stop time because, in
this case, the modulating signals are constant. Compared to the preceding
examples, which use a sample time of 1/20*1e-9, this model simulates
accurately with a time step 100 times larger. This step size results in a
reduction of total sample time by a factor of 100, excluding the initial time
step at time 0.

1-11
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Using SimRF Software for the First Time

In this section...

“Expected Background” on page 1-12

“Circuit Envelope, Equivalent Baseband, and Idealized Baseband Library
Features” on page 1-12

“Understanding the SImRF Environment” on page 1-14

Expected Background

Topics in the SimRF documentation assume that you are already familiar
with:

e Using MATLAB® to write and execute scripts and functions.

® Using Simulink to create and simulate block diagrams.

Circuit Envelope, Equivalent Baseband, and Idealized
Baseband Library Features

SimRF software offers Circuit Envelope, Equivalent Baseband, and Idealized
Baseband libraries for modeling RF networks. Each library represents a
distinct simulation paradigm. For certain applications, one library may offer
an advantage over another.

e Use the Circuit Envelope library for large, multicarrier simulation of RF
networks with arbitrary topologies.

e Use the Equivalent Baseband library for single-carrier simulation of
cascaded RF networks.

e Use the Idealized Baseband library for basic, behavioral simulation of
highly abstracted, Simulink-domain RF devices.

Except for the cross-domain SimRF Inport, SimRF Outport, Input Port, and
Output Port blocks, blocks from the three libraries do not connect to each
other. Therefore, to avoid redesigning your model later, choose which library
to use based on your application. You can consult the following table for a
summary of the features of the three libraries.
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(Continued)

Do blocks in
this library...

Circuit
Envelope
Library

Equivalent
Baseband
Library

Idealized
Baseband
Library

Connect directly
to Simulink
blocks?

No, except for
cross-domain

blocks

No, except for
cross-domain
blocks

Yes

Support
single-carrier
simulation?

Yes

Yes

Yes

Support
multicarrier
simulation?

Yes

No

No

Support
third-order
nonlinear
simulation?

Yes

Yes

Support

fifth- and
seventh-order
nonlinear
simulation?

Yes

Support
simulation
of cascaded
networks?

Yes

Yes

Yes

Support
simulation

of networks
with arbitrary
topologies?

Yes

Support signal
probing between
input and
output?

Yes

Yes
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(Continued)

Do blocks in
this library...

Circuit
Envelope
Library

Equivalent
Baseband
Library

Idealized
Baseband
Library

Support noise
simulation?

Yes

Yes

No

Support

Yes

No

No

Simscape™
platform
features, such
as local solvers?

Support Yes Yes No
specification
using network
parameter data?

Understanding the SimRF Environment

Groups of interconnected SimRF Circuit Envelope library blocks and the
algorithms that model the RF system that they represent comprise the SimRF
environment. In the SImRF environment, all blocks fall into one of the three
following categories.

Blocks that Operate Within the SimRF Environment

These blocks contribute to the physical representation of an RF system. Most
SimRF Circuit Envelope library blocks fall into this category, including all
blocks in the SimRF Elements and Sources libraries. For example, a Resistor
block can model a source impedance or part of a matching network, and an
Amplifier block could model a physical RF amplifier. Both of these blocks
model physical components.

Blocks within the SimRF environment connect via bidirectional SimRF
signals. SimRF signals are an implementation of Simscape physical signals
whose defined Through and Across variables represent current and voltage,
respectively. For an introduction to Simscape software and physical signals,
see Basic Principles of Modeling Physical Networks.
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Blocks that Convert Between the SimRF and Simulink
Environments

These blocks, also called cross-domain blocks, provide an interface from an
RF system to a larger design. SimRF Inport and SimRF Outport blocks fall
into this category. For example, you can construct a signal using blocks from
Communications System Toolbox™ or DSP System Toolbox™ libraries, and
input that signal into the SimRF environment using a SimRF Inport block.

The SimRF Parameters and Solver Configuration blocks

These blocks manipulate the environment itself. They are not strictly part of
the physical system. However, they connect directly with other SimRF blocks
using physical connections. To use these blocks, connect them to any part of
the RF system. Because they are not part of the physical representation of the
system, they have the same effect regardless of where they connect within
the environment.

To run models containing SimRF blocks, you must connect a Solver
Configuration block to the SimRF environment. Additionally, to simulate
carriers besides 0 Hz, or to model noise in the SImRF environment, you must
connect a SimRF Parameters block to the SimRF environment.

1-15
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o “Specify the Circuit Envelope Simulation Environment” on page 2-2
e “Model an RF Mixer” on page 2-6
¢ “Filter Mixing Products” on page 2-14
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Specify the Circuit Envelope Simulation Environment

In this section...

“Access Circuit Envelope Libraries” on page 2-2
“Ground the RF System” on page 2-3
“Configure the SimRF Environment” on page 2-3

“Simulate the SimRF Environment” on page 2-4

This section of the tutorial shows you how to:
e Use a Solver Configuration block to provide local solver settings to the
SimRF environment

¢ Use a SimRF Parameters block to define the carriers and global noise
behavior in the SimRF environment.

e Use a Ground block to reference a model to electrical ground.

The Solver Configuration and Ground block are the bare minimum that
SimRF software requires in order to perform circuit-envelope simulation.
Models that are missing one of these two blocks do not run. In order to
simulate the SimRF environment at carrier frequencies other than 0 Hz, a
model must also contain a SimRF Parameters block.

To begin, open a new model by selecting File > New > Model.
Access Circuit Envelope Libraries
Open the SimRF library by typing

simrflib

at the MATLAB Command Window prompt.

Equivalent Baseband Idealized Baseband

Circuit Envelope ‘

SimRF Library 3.3
Copyright 2003-2012 The MathWorks, Inc.
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The SimRF library contains three sublibraries:

® The Circuit Envelope library contains blocks for circuit-envelope
simulation. This manual often refers to the Circuit Envelope library as the
SimRF library. The SimRF Getting Started Guide and SimRF User’s Guide
pertain exclusively to this library.

¢ The Equivalent Baseband and Idealized Baseband library contain blocks for
equivalent-baseband simulation. Refer to the Equivalent Baseband section
of the SImRF documentation for more information on using these blocks.

To continue, double-click the Circuit Envelope library.

Ground the RF System

Place a Ground block in your model:

1 In the SimRF library, double-click Elements to open the SimRF Elements
library.

2 Drag and drop a Ground block onto your model. In the library, the block
is abbreviated ‘Gnd’.

Connecting SimRF models to ground provides an electrical reference for the
system, from which node voltages are defined. A SimRF model is grounded if:

® The model contains a Ground block that connects to the SImRF
Environment, or

¢ The model contains an Amplifier, Continuous Wave, Mixer, Noise,
Sinusoid, or S-Parameters block that is internally grounded. To internally
ground one of these blocks, select the Ground and hide negative
terminals check box in the block dialog box.

Configure the SimRF Environment
To continue the tutorial:

1 Place a Solver Configuration block in your model. In the SimRF library,
double-click Utilities to open the SimRF Utilities library, then drag and
drop a Solver Configuration block onto your model.

2-3
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2 Place a SimRF Parameters block in your model. If the SimRF Utilities
library is not already open, double-click Utilities to open it, then drag and
drop a SimRF Parameters block onto your model.

3 Connect the Ground, Solver Configuration, and SimRF Parameters blocks
to each other. The following figure shows one possible configuration.

A model can contain multiple Solver Configuration and SimRF Parameters if
all of the following conditions are met:

¢ Each Solver Configuration and SimRF Parameters block connects to a
separate SimRF environment.

® No two Solver Configuration or SimRF Parameters blocks connect to the
same environment.

® The separate SimRF environments are isolated from each other in separate
subsystems.

Warning Simulating more than one SimRF environment without
using subsystems is not supported.

Simulate the SimRF Environment
To run the model, select Simulation > Run.

The model simulates according to the default settings of the Solver
Configuration and SimRF Parameters blocks and produces no output:

¢ In the SimRF Parameters block dialog, the Carrier frequencies
parameter specifies a carrier of 0 Hz in the system. In the next section,
“Model an RF Mixer” on page 2-6, you specify additional carriers for
circuit-envelope simulation.

¢ In the Solver Configuration block dialog, the Use local solver check box is
cleared, so the model uses the specified global solver. The examples in the
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SimRF User’s Guide show you how to configure the SimRF environment
to use a local solver.

2-5
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Model an RF Mixer

In this section...

“Build the RF System” on page 2-7

“Probe Circuit Envelopes Waveforms” on page 2-7

“Define Model Variables” on page 2-8

“Specify Block Parameters for RF Simulation” on page 2-11

“Simulate Frequency Conversion in an RF Mixer” on page 2-12

This section of the tutorial shows you how to:

e Use a Sinusoid block to model the envelope of an amplitude-modulated
(AM) waveform.

® Use a Continuous Wave block to model the constant envelope of an ideal
local oscillator (LO).

e Use a Mixer block to downconvert the AM waveform to an intermediate
frequency (IF).

i fir

fig fro ey

The preceding figure illustrates frequency conversion. A signal modulated on
the carrier f,, mixes with a local oscillator at f; . The operation downconverts
fri to fip = frr— f1o0- The upper mixing product f,z + f; is not modeled.

To begin, open the model you created in the previous section, “Specify the
Circuit Envelope Simulation Environment” on page 2-2, or type

ex_simrf_tut_env

2-6
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at the MATLAB Command Window prompt.

Build the RF System

Add blocks to the SimRF environment that create a working model for
frequency conversion:

® From the SimRF Sources library, drag and drop a Continuous Wave block
and a Sinusoid block onto your model.

®* From the SimRF Elements library, drag and drop a Mixer block and a
Resistor block onto your model.

Connect the blocks as shown in the following figure.

This configuration specifies an AM waveform at the input port of the mixer,
an LO at the LO port of the mixer, and a 50-Q termination at the output
of the mixer.

For more information on organizing blocks on the Simulink canvas, see
“Change the Appearance of a Block” in the Simulink User’s Guide.

Probe Circuit Envelopes Waveforms
At the output of the mixer:

® From the SimRF Utilities library, drag and drop a SimRF Outport block
onto your model.

2-7
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®* From the Simulink Commonly Used Blocks library, drag and drop a Scope
block and a Terminator block onto your model.

Connect the blocks as shown in the following figure.

This configuration uses a SimRF Outport block as a voltage sensor at the
output port of the mixer. The Simulink signal at the outport is the envelope of
the carrier or carriers specified in the block. A scope attached to the outport
plots the envelope. The Output parameter controls how signals are presented
at the output ports. To change the appearance of the block, follow one of

the workflows in the “Specify Block Parameters for RF Simulation” on page
2-11 section of this tutorial.

Define Model Variables

For models with blocks that share parameter values, specifying parameters
values using variables saves time and effort. For example, a frequency that
1s specified in the Carrier frequencies parameter of a SimRF Inport block
must also be specified SimRF Parameters block also appears in the Carrier
frequencies parameter of a block that uses that carrier. If you specify the
parameter with a variable for the model using one of the following procedures.

To define model variables, use one of the following workflows.

Using an Initialization Function to Define Variables

Simulink models run MATLAB code stored in the initialization function
(InitFcn) each time the model starts. The MATLAB code runs in the base
workspace. If the initialization function stores variables in the MATLAB
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workspace, the variables are overwritten every time the model executes the
Initialization function.

Most models in the SimRF User’s Guide use the InitFcn to define model
variables.

1 Open the Model Properties dialog box by selecting File > Model
Properties.

2 In the Callbacks tab, within the Model callbacks pane, select the
InitFcn node.

3 In the Model initialization function pane, enter the following MATLAB
code:

modulationAmplitude = 1;
modulationFrequency 5e5;
LOAmplitude = 1;
LOFrequency = .95e9;
RFCarrier = 1e9;

For more information, see Using Callback Functions in the Simulink User’s
Guide.

Using the Model Explorer to Define Variables
From within the Model Explorer, add variables directly to the model

workspace. Model workspace variables do not interact with the base MATLAB
workspace.

1 Open the Model Explorer window by selecting View > Model Explorer,
or by right-clicking a block in your model and from the context menu,
selecting Explore.

2 On the Model Hierarchy pane, select the Model Workspace node for
your model.

3 On the Contents pane, add the following variables to the workspace by
selecting Add > MATLAB Variable and editing the variable attributes.
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Name Value
modulationAmplitude 1
modulationFrequency 500000
LOAmplitude 1

LOFrequency .95e+009
RFCarrier 1e+009

Madel Hierarchy € 9 = Contentsoft M
4 ¥ simulink Raot P \E

HH Base warkspace
4 ex_simrf_tut_mixer
Ol Model Warkspace
E Code for ex_simrf_tut_mixer
() Advice For ex_simrf_tut_ mixer
¥ Simulink Design Verifier results
& Configuration [Adtive) [ LOAmplitude
[ RFCarrier

Mame
[ modulationFreq
HH LoFrequency
£ modulationAmp

For more information, see The Model Explorer: Overview in the Simulink
User’s Guide.

Using the Command Line to Define Variables

Execute the MATLAB code in this section at the command line to assign
variables directly into a model workspace.

In the Command Prompt window, type:

hmdl = bdroot;

hws = get_param(hmdl, ‘ModelWorkspace');
hws.assignin('modulationAmplitude’',1);
hws.assignin('modulationFrequency',5e5);
hws.assignin('LOFrequency',.95€9);
hws.assignin('LOAmplitude’',1);
hws.assignin('RFCarrier',1e9);



Model an RF Mixer

For more information on manipulating model workspace data, see Using
Model Workspaces in the Simulink User’s Guide.

Specify Block Parameters for RF Simulation
In this section, you:

¢ Configure the SImRF environment for multi-frequency circuit-envelope
simulation by specifying the Carrier frequencies parameter in the
SimRF Parameters block dialog box.

® Specify the attributes of the waveforms

e Configure global simulation settings.

To specify block parameters, use one of the following workflows.

Using Dialog Boxes to Set Parameters

1 Select Simulation > Model Configuration Parameters to open the
Configuration Parameters dialog box. Specify the following parameters:
® Set Stop time to 1e-5.
® Set Solver to ode23t (mod. stiff/Trapezoidal).

2 Double-click the Sinusoid block to open the Sinusoid Block Parameters
dialog box. Specify the following parameters:

® Set Sinusoidal amplitude in-phase to modulationAmplitude.
® Set Sinusoidal modulation frequency to modulationFrequency.

e Set Carrier frequencies to RFCarrier.

3 Double-click the Continuous Wave block to open the block dialog box.
Specify the following parameters:

¢ Set Constant in-phase value to LOAmplitude.

¢ Set Carrier frequencies to LOFrequency.
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4 Double-click the SimRF Parameters block to open the block dialog box, and
set Carrier frequencies to [RFCarrier - LOFrequency, LOFrequency,
RFCarrier, RFCarrier + LOFrequency].

5 Double-click the SimRF Outport block to open the block dialog box. Specify
the following parameters:

e Set Output to In-phase and quadrature.

e Set Carrier frequencies to RFCarrier - LOFrequency.

Using the Command Line to Set Parameters

Execute the MATLAB code in this section at the command line to assign
variables directly into a model workspace.

In the Command Prompt window, type:

hmdl = bdroot;
set_param(hmdl, 'StopTime', '1e-5');
set_param(hmdl, 'Solver', 'ode23t');
set_param([hmdl '/Sinusoid'],
'VA_I','modulationAmplitude’,
'Fmod', 'modulationFrequency’,
'CarrierFreq', 'RFCarrier');
set_param([hmdl '/Continuous Wave'],
"IVoltage', 'LOAmplitude’,
'CarrierFreq', 'LOFrequency');
set_param([hmdl '/SimRF Outport'],
'CarrierFreq', 'RFCarrier - LOFrequency',
"OutputFormat', 'In-phase and quadrature');
set_param([hmdl '/SimRF Parameters'],
‘CarrierFreq',['[RFCarrier - LOFrequency, '
'LOFrequency, '
'RFCarrier, '...
'RFCarrier + LOFrequency]'l);

Simulate Frequency Conversion in an RF Mixer
Select Simulation > Run to run the model.
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Models that contain SimRF Amplifier and Mixer blocks generate files at
update time. Before you can successfully update and run models with these
blocks, you have to set up a compiler by running mex -setup.

By default, SImRF software generates files in the current MATLAB folder.
However, you can change the output location for these files by specifying a
cache folder in the Simulink Preferences dialog. To specify a cache folder:

1 On the Home tab, in the Environment section, click Preferences.

2 Click Simulink, then click Launch Simulink Preferences.

3 Specify the Simulink cache folder parameter.

To view the results of the simulation, double-click the scope.

8 Scope E=8 Bl =
SB|([OLL AEEB B AT o

The Sinusoid specifies a 1-V amplitude for the modulation on f,,, which the
mixer downconverts to f, The SImRF Outport block probes the intermediate
frequency and recovers the 1-V modulation amplitude. This value agrees with
a specified conversion gain of 0 dB in the mixer.
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Filter Mixing Products

2-14

In this section...

“Probe Multiple RF Carriers” on page 2-15
“Model an RF Filter” on page 2-16

“Simulate Filtering of RF Signals” on page 2-17

This section of the tutorial shows you how to:
e Configure a SimRF Outport block to probe multiple carrier frequencies
simultaneously.

e Model an analog filter in the SimRF environment using SimRF Capacitor
and Inductor blocks.

a

Low-pass filter 7=,
transmission

iiF Fro far fae + o

The preceding figure illustrates low-pass filtering of a low-side injection
system. Mixing f,, and f;, produces signals on the carriers f,, = fpr— f, and
frr + fLo- Adding a low-pass filter to the model reduces the power present

in the high-frequency signal.

To begin, open the model that you created in the “Model an RF Mixer” on
page 2-6 section, or type

ex_simrf_tut_mixer

at the Command Window prompt.
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Probe Multiple RF Carriers

The SimRF environment specifies the carriers fpn— f10, frp fro» a0d frp + L0
but the SimRF Outport block probes only the carrier fp, — f, . Examine

the carriers f,, — f,, and fpp + f,, by changing the model according to the
following workflow:

1 From the Simulink Commonly Used Blocks library, add a Demux block to
your model.

2 In the Scope block dialog box, click the Parameters button, then set
Number of Axes to 2.

3 In the SimRF Outport block dialog box, set Carrier frequencies to
[RFCarrier - LOFrequency, RFCarrier + LOFrequency]

4 Connect the blocks as shown in the following figure.

n
Lo 1 ot— 5
- g - Terminstor
Simuscid o
.

Scope

5 Select Simulation > Run to run the model.

Models that contain SimRF Amplifier and Mixer blocks generate files at
update time. Before you can successfully update and run models with these
blocks, you have to set up a compiler by running mex -setup.

By default, SImRF software generates files in the current MATLAB folder.
However, you can change the output location for these files by specifying a

cache folder in the Simulink Preferences dialog. To specify a cache folder:

1 On the Home tab, in the Environment section, click Preferences.
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2 Click Simulink, then click Launch Simulink Preferences.
3 Specify the Simulink cache folder parameter.

To view the results of the simulation, double-click the scope.

B scope = Bl )
2w OF% D& & -

The first set of axes displays the modulation of specified carrier fz = frr— f10-
This carrier appears on the first set of axes because the Carrier frequencies
parameter of the outport specifies it first. The second set of axes displays the
modulation at fpr + f; . The modulation of the upper mixing product has the
same amplitude as the modulation of the downconverted signal.

Model an RF Filter
To begin, open the model that you created in the “Probe Multiple RF Carriers”
on page 2-15 section, or type

ex_simrf_tut_probe
at the MATLAB Command Window prompt.

1 From the Elements library, drag and drop one Capacitor and two Inductor
blocks onto your model

2 Set the Capacitance parameter of the capacitor to 40e-12 F.
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3 Set the Inductance parameter of both inductors to 50e-9 H.

4 Connect the blocks as shown in the following figure.

Scope
Out p——e """ o—qg RF
Rou =

R

Lo L
Terminator
Mcer c o A SimRF
Cutport
. Continuous ]‘
Sinuscid Were )
Sahver 3
Configurstion
= SimRF
= o Pt

This configuration models a third-order low-pass Butterworth filter with
a cutoff frequency of 1 rad/ns, or about 0.159 GHz. The high-frequency
mixing product is in the stopband of the filter. The low-frequency product
1s in the passband.

2]

Simulate Filtering of RF Signals

To begin, open the model that you created in the previous section, “Model
an RF Filter” on page 2-16, or type

ex_simrf_tut_filter

at the MATLAB Command Window prompt. Select Simulation > Run to
run the model.

To view the results of the simulation, double-click the scope.
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2-18

B scope (=5 ESR
2@ a<wfHOfS% 0a 5 ~

Time offset: 0

The filter attenuates the high-frequency signal at f,, + f;, and transmits the
signal at f, — f,, with minimal loss.

The SimRF documentation contains additional RF filter analysis and
simulation examples:

® The example Model an RF Filter Using S-Parameter Data uses an
S-Parameters block to model the filter shown in this tutorial.

¢ The example AC Analysis of an RF System calculates the voltage transfer
function of an RF filter using harmonic balance analysis.
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¢ “SimRF Equivalent Baseband Libraries” on page 3-2
¢ “Equivalent Baseband Workflow” on page 3-8
® “Model an LLC Bandpass Filter” on page 3-10
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SimRF Equivalent Baseband Libraries

In this section...

“Overview of SImRF Equivalent Baseband Libraries” on page 3-2
“Open SimRF Equivalent Baseband Libraries” on page 3-3
“Physical Library” on page 3-4

“Mathematical Library” on page 3-6

Overview of SimRF Equivalent Baseband Libraries

The SimRF Equivalent Baseband libraries consist of the Equivalent Baseband
(physical) and Idealized Baseband (mathematical) libraries of components for
modeling RF systems within the Simulink environment. An RF model can
contain blocks from both the physical and mathematical libraries. It can also
include Simulink blocks and blocks from other blocksets.

SimRF Equivalent Baseband software extends your Simulink modeling
environment with a library of blocks for modeling RF systems that include RF
filters, transmission lines, amplifiers, and mixers.

You use SimRF Equivalent Baseband library blocks to represent the
components of your RF system in a Simulink model. The blockset provides
several types of component representations using network parameters (S, Y, Z,
ABCD, H, and T format), mathematical descriptions, and physical properties.

In the Simulink model, you cascade the components to represent your RF
architecture and run the simulation. During the simulation, the model
computes a time-domain, complex-baseband representation. This method
results in fast simulation of the quadrature modeling schemes used in modern
communication systems and enables compatibility with other Simulink blocks.

The blocks let you visualize their specified network parameters using plots
and Smith® Charts.

A validated Simulink model of an RF system can provide an executable
specification for RF circuit design for wireless communication systems.
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You can also use the blockset with Simulink Coder™ software to generate
embeddable C code for real-time execution.

Open SimRF Equivalent Baseband Libraries
To open the main library window, type the following at the MATLAB prompt:

rflib

Each yellow icon in the window represents a library. Double-click an icon to
open the corresponding library.

W Library: rflibvl = e =

File Edit View Format Help

=+ @ B o

Mathematical Physical Demos Info

SimRF Baseband Libraries 3.0.1
Uses: 'SP System Toolbox
Copyright 2002-2010 The MathWerks, Inc.

For a discussion of the Physical and Mathematical libraries, see the following
sections.

Note The blue icons take you to the MATLAB Help browser.

¢ Double-click the Demos icon to open the SimRF Equivalent Baseband
examples.

¢ Double-click the Info icon to open the SimRF Equivalent Baseband
documentation.
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Physical Library

Use blocks from the Physical library to model physical and electrical
components by specifying physical properties or by importing measured
data. The Physical library includes several sublibraries, as shown in the
following figure.

W Library: rfphysmodelsl [F=8 =8 =
File Edit View Format Help
~wl I =
T I ——
E—J
Ladder Series/Shunt  Transmission
Filters RLC Lines
8.8 —{é)—
11 Py [>
I:Sn Sm]
Black Box Amplifiers Mixers
Elements
—Je
oo
Input/Qutput
Parts

imRF Egquivalent Baseband Library 32.0.°

Uses: DSP System Tocolbox
Copyright 2003-2010 The MathWorks, Inc

The following table describes the sublibraries and how to use them.
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Sublibrary

Description

Amplifiers

RF amplifiers, specified using
network parameters, noise data,
and nonlinearity data, or a data file
containing these parameters.

Ladder Filters

RF filters, specified using L.C
parameters. The software calculates
the network parameters and noise
data of the blocks from the topology
of the filter and the LC values.

Series/Shunt RLC

Series and shunt RLC components
for designing lumped element
cascades, specified using RLC
parameters. The software calculates
the network parameters and noise
data of the blocks from the topology
of the components and the RLC
values.

Mixers

RF mixers that contain local
oscillators, specified using network
parameters, noise data, and
nonlinearity data, or a data file
containing these parameters.

Transmission Lines

RF filters, specified using physical
dimensions and electrical
characteristics. The software
calculates the network parameters
and noise data of the blocks from the
specified data.
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Sublibrary Description

Black Box Passive RF components, specified
using network parameters, or a data
file containing these parameters.
The software calculates the network
parameters and noise data of the
blocks from the specified data.

Input/Output Ports Blocks for specifying simulation
information that pertains to all
blocks in a physical subsystem, such
as center frequency and sample time.

Note A physical subsystem is a
collection of one or more physical
blocks bracketed by an Input
Port block and an Output Port
block that bridge the physical and
mathematical parts of the model.

For more information on defining components, see “Specify or Import
Component Data”.

Mathematical Library

The Mathematical library contains mathematical representations of the
amplifier, mixer, and filter blocks. Use a block from the Mathematical library
to model an RF component in terms of mathematical equations that describe
how the block operates on an input signal.

Mathematical blocks assume perfect impedance matching and a nominal
impedance of 1 ohm. This means there is no loading and the power flow is
unidirectional. As such, they are similar to standard Simulink blocks. In
contrast, the physical blocks do not assume perfect matching—these blocks
model the reflections that occur between blocks. Physical blocks model
bidirectional power flow, and include loading effects. For these blocks, you
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can specify the source and load impedances using the Input Port and Output
Port blocks.

The mathematical library is shown in the following figure.

W Library: fmathmodelsl EI@

File Edit View Format Help

>

Amplifier Mixer

S i
L g
A L

Bandpass RF Filter  Bandstop RF Filter

THEOe | | T
T e B TR
[ N

Lowpass RF Filter Highpass RF Filter

S3imAF Ideslized Baseband Library 3.0.1

Uses: DSP System Toolbox
Copyright 2003-2010 The MathWers, Inc.
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Equivalent Baseband Workflow

When you analyze an RF system using SimRF Equivalent Baseband software,
your workflow might include the following tasks:

1 Create a Simulink model that includes RF components.
For more information , see “Model RF Components”.

2 Define component data by

® Specifying network parameters, mathematical relationships, or physical
properties

¢ Importing data from an industry-standard Touchstone file, a
MathWorks™ AMP file, an Agilent® P2D or S2D file, or the MATLAB
workspace

The product lets you access component data in Touchstone SnP, YnP,
ZnP, HnP, and GnP formats. You can also import amplifier network
parameters and power data from a MathWorks AMP file.

For more information, see “Specify or Import Component Data”.

3 Where applicable, add the following information to the component
definition:

¢ Operating condition values (see “Specify Operating Conditions”).
® Nonlinearity data (see “Model Nonlinearity”).

® Noise data (see “Model Noise”).

4 Validate the behavior of individual blocks by plotting component data.

Note You can plot data for individual blocks from the Physical library that
model physical components either before or after you run a simulation.

For more information, see “Create Plots”.

5 Run the simulation.
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For more information on how the product performs time-domain simulation
of an RF system, see “Simulate an RF Model”.

Generate plots to gain insight into system behavior.
For more information, see “Create and Modify Subsystem Plots”.

The following plots and charts are available:

e Rectangular plots

Polar plots
Smith Charts

Composite plots

Budget plots

3-9



3 Introduction to Equivalent Baseband Simulation

3-10

Model an LC Bandpass Filter

In this section...

“Overview of LC Bandpass Filter Example” on page 3-10

“Select Blocks to Represent System Components” on page 3-10
“Build the Model” on page 3-11

“Specify Model Parameters” on page 3-13

“Validate Filter Components and Run the Simulation” on page 3-20

“Analyze the Simulation Results” on page 3-22

Overview of LC Bandpass Filter Example

In this example, you model the signal attenuation caused by an RF filter by
comparing the signals at the input and output of the filter.

The RF filter you use in this example is an LC bandpass filter with a
bandwidth of 200 MHz, centered at 700 MHz. You use a three-tone input
signal to stimulate a range of in-band and out-of-band frequencies of the filter.
The input signal has the following tones:

e 700 MHz — Center of the filter
® 600 MHz — Lower edge of the filter passband
® 900 MHz — Outside the filter passband

You simulate the effects of the filter over a bandwidth of 500 MHz.

Select Blocks to Represent System Components

In this part of the example, you select the blocks to represent the input signal,
the RF filter, and the signal displays.

You model the RF filter using a physical subsystem, which is a collection of
one or more physical blocks bracketed by an Input Port block and an Output
Port block. The RF filter subsystem consists of an LLC Bandpass Pi block, and
the Input Port and Output Port blocks. The function of the Input Port and
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Output Port blocks is to bridge the physical part of the model, which uses
bidirectional RF signals, and the rest of the model, which uses unidirectional

Simulink signals.

The following table lists the blocks that represent the system components and
a description of the role of each block.

Block

Description

Sine Wave

Generates a three-channel signal.

Matrix Sum

Combines the three channel signal into a single
three-tone source signal.

Input Port

Establishes parameters that are common to all
blocks in the RF filter subsystem, including the
source impedance of the subsystem that is used to
convert Simulink signals to the SimRF Equivalent
Baseband physical modeling environment.

LC Bandpass Pi

Models the signal attenuation caused by the RF filter
which, in this example, is the LC Bandpass Pi filter.

Output Port

Establishes parameters that are common to all
blocks in the RF filter subsystem. These parameters
include the load impedance of the subsystem, which
1s used to convert RF signals to Simulink signals.

Spectrum Scope

Displays signals at the input to and output of the
filter.

Build the Model

In this part of the example, you create a Simulink model, add blocks to the
model, and connect the blocks.

1 Create a model with the blocks shown in the following table. The Library
column of the table specifies the hierarchical path to each block.
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Block Library Path Quantity

Sine Wave DSP System Toolbox > Sources 1

Matrix Sum DSP System Toolbox > Math 1
Functions > Matrices and Linear
Algebra > Matrix Operations

Spectrum Scope DSP System Toolbox > Sinks 2

Input Port SimRF > Equivalent Baseband > Equivalent 1
Baseband > Input/Output Ports

LC Bandpass Pi SimRF > Equivalent Baseband > Ladder Filters | 1

Output Port SimRF > Equivalent Baseband > Input/Output |1

Ports

2 Connect the blocks as shown in the following figure.

For more information on connecting physical and mathematical blocks,
see “Connect Model Blocks”.

o
File Edit View Simulaton Format Tools Help
DI EHS| fER|E=>4 2] » 5o || AEREE nERE
5P
|J—L|: - g InPUL Qutput - M
FET
Sine Wave Matrix LC Bandpass Pi Spectum

Ready

Sum Input Part

o{

FFT

Spectrum
Scope

Cutput Port

Scope 1

[100%

[ode4s

Now you are ready to specify block parameters.
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Specify Model Parameters

In this part of the example, you specify the following parameters to represent
the behavior of the system components:

¢ “Input Signal Parameters” on page 3-13
¢ “Filter Subsystem Parameters” on page 3-15

e “Signal Display Parameters” on page 3-19

Input Signal Parameters

You generate the three-tone source signal using two blocks. You use the Sine
Wave block to generate a complex three-channel signal, where each channel
corresponds to a different frequency. Then, you use the Matrix Sum block to
combine the channels into a single three-tone source signal. Without this
block, the signal in all subsequent blocks would have three independent
channels.

The SimRF Equivalent Baseband simulation algorithm requires you to
shift the frequencies of the input signal. The software simulates the

filter subsystem using a complex-baseband modeling technique, which
automatically shifts the filter response and centers it at zero. You must shift
the frequencies of the signals outside the physical subsystem by the same
amount.

For more information on complex-baseband modeling, see “Create a Complex
Baseband-Equivalent Model”.

Note All signals in the RF model must be complex to match the signals in
the physical subsystem, so you create a complex input signal.

The center frequency of the LLC bandpass filter is 700 MHz, so you use a
three-tone source signal with tones that are 700 MHz below the actual tones,
at -100 MHz, 0 MHz, and 200 MHz, respectively.

1 In Sine Wave block dialog box:
® Set the Amplitude parameter to 1e-6.
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Set the Frequency (Hz) parameter to [-100 0 200] *1e6.

Set the Output complexity parameter to Complex.

Set the Sample time parameter to 1/500e6.

Set the Samples per frame parameter to 128 .

E! Source Block Parameters: Sine Wave x|

Sine Wawe [mazk)] [ink)

Output zamples of a sinuzoid. Tao generate mare than one sinuzaid
simultaneously, enter a vector of values for the Amplitude,
Frequency, and Phase offzet parameters.

Main IDataTypes I
Amplitude:

e

Frequency [Hz):

{100 0 20071 ef

Phaze offset [rad]:
jo

Sample mode:l Discrete

Output cnmple:-tity:l Cornples

Lel Lef |«

Cornputation methnd:l Trigonarmetric fon

Sample time:
|1/500e5

Samples per frame;
126

Fezetting states when re-enabled; | Restart at time zero ;I

Cancel | Help |

2 In the Matrix Sum block dialog box:
® Set the Sum over parameter to Specified dimension.

e Set the Dimension parameter to 2.
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x

Sum

Add ar subtract inputs. Specify one of the following:

a) string containing + ar - for each input port, | for spacer between ports (g.g. ++|-|++)
b) scalar, == 1, specifies the number of input ports to be summed.

When there is only one input port, add or subtract elements over all dmensions or one
specified dimension

Main | Signal Attributes

Icon shape: Irectangular LI
List of signs:

+
Sum over: |Specified dimension LI
Dimensian:

|2
Sample time {-1 for inherited):

|-1

J- QK I Cancel Help Apply

Filter Subsystem Parameters
In this part of the example, you configure the blocks that model the RF filter

subsystem—the Input Port, LC Bandpass Pi, and Output Port blocks.
1 Set the Input Port block parameters as follows:
¢ Treat input Simulink signal as = Incident power wave

This option tells the blockset to interpret the input signal as the incident
power wave to the RF subsystem, and not the source voltage of the RF
subsystem.
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Note If you use the default value for this parameter, the software
interprets the input Simulink signal as the source voltage. As a result,
the source and the load that model the Input Port and Output Port
blocks, respectively, introduce 6 dB of loss into the physical system at
all frequencies. For more information on why this loss occurs, see the
note in “Convert to and from Simulink Signals”.

Center frequency = 700e6
Sample time (s) = 1/500e6

Clear the Add noise check box so the software does not include noise in
the simulation. To learn how to model noise, see “Model Noise”.
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5] Block Parameters: Input Port x|

—Input Port
Connection block fram Simulink to RF Blockset physical blocks.

The RF Elockset physical blocks use a baseband-equivalent modeling technique.
This technique models a bandwidth of 1/{Sample time), centered at the specified
Center frequency parameter value. This frequency value corresponds to 0 Hz in
the baseband-equivalent model.

The block provides the option to interpret the Simulink signal as either the incident
power wave to the RF system ar the source voltage of the RF system. The
‘Incident power wave' option is the most comman RF modeling interpretation,

while the 'Source voltage' option is provided for backwards compatibility. If the
input Simulink signal is the incident power wave, the output of the RF system is the
transmitted power wave. If the input is the source voltage, the output

is the load voltage.

The block controls the modeling of RF Blockset physical blocks between this block
and the Qutput Port block using:

-FIR filters to model the frequency-dependent characteristics

- Look-up tables to model the nonlinear behaviors

Optional quard bands can be specified as a fraction of the modeling bandwidth.
The guards bands are implemented by applying a Tukey window to the frequency
response. Modeling delay may be added to improve the response of the FIR filters,

—Parameters
Treat input Simulink signal as: IIncident DOWET Wave ;I
Source impedance (ohms): I 50

Finite impulse response filter length: I 128

Fractional bandwidth of guard bands: ID

Modeling delay {samplas): ID
Center frequency {(Hz): I 700ed
Sample time (s): I 1/500e6
[T Add noise

Initial seed: |67987

oK I Cancel | Help Apply
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Note You must enter the Sample time (s) because the Input Port block
does not inherit a sample time from the input signal. The specified sample
time must match the sample time of the input signal. The Sample time
(s) of 1/500e6 second used in this example is equivalent to a bandwidth
of 500 MHz.

2 Accept default parameters for inductance and capacitance in the LC
Bandpass Pi block. These parameters create a filter with the desired
bandwidth of 200 MHz, centered at 700 MHz.

E Block Parameters: LC Bandpass Pi x|

’7LC Bandpaszz Pi

todel an LC bandpass pi network,

IVisuaIization |

Inductance [H): |[1.444Be-9 4.25945e-8 1.444Ee-9]
Capacitance [F: |[3.5?858-11 1.1762e-12 3.5785e-11]

QK I Cancel Help Apply

3 Accept the default parameters for the Output Port block to use a load
impedance of 50 ohms.
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E Block Parameters: Dutput Pork x|

Cutput Port

Connection black fram BF Blockzet physical block s ta Simulink.

After running a simulation, various parameters of the BF system that is delimited by an
Input Part black and this Qutput Part block. can be visualized.

M ain Yizualization I

Load impedance [ohms]): IED

0k I Cancel Help Apply

Signal Display Parameters
In this part of the example, you specify:

® The parameters of the Spectrum Scope block to display the source signal
® The parameters of the Spectrum Scopel block to display the filtered signal

For each scope, you set the range of the x- and y-axes to make sure that the
entire signal is visible.

By default, the scope displays appear stacked on top of each other on the
screen when you run the simulation, so you can only see one of them. To
ensure that both scopes are visible during the simulation, you specify a
different position for each scope on the screen.

1 In the Spectrum Scope block dialog box:

® In the Scope Properties tab, set the Spectrum units parameter to
dBm.

¢ In the Display Properties tab, set the Scope position parameter to
get (0, 'defaultfigureposition').*[.15 1 1 1]

¢ In the Axis Properties tab, set the Minimum Y-limit parameter to
-220.
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¢ Inthe Axis Properties tab, set the Maximum Y-limit parameter to - 80

¢ In the Axis Properties tab, set the Y-axis label parameter to dBm.

2 Set the Spectrum Scopel block parameters as follows:

¢ In the Scope Properties tab, set the Spectrum units parameter to
dBm.

¢ In the Display Properties tab, set the Scope position parameter to
get (0, 'defaultfigureposition').*[1.85 1 1 1]

¢ In the Axis Properties tab, set the Minimum Y-limit parameter to
-220.

¢ Inthe Axis Properties tab, set the Maximum Y-limit parameter to -80

¢ In the Axis Properties tab, set the Y-axis label parameter to dBm.

Note If you do not specify the position of the scopes using the Display
Properties tab, you can click and drag the displays to arrange them on the
screen after the simulation starts.

Validate Filter Components and Run the Simulation

In this part of the example, you validate the behavior of the LC Bandpass Pi
filter block by plotting its frequency response and then run the simulation.

Note When you plot information about a physical block, the plot displays
the actual frequency response of the block at the selected passband (i.e.,

the response at the unshifted frequencies), not the response at the shifted
frequencies. For more information on this shift, see “Input Signal Parameters’
on page 3-13.

i

1 Double-click the LC Bandpass P1 block to open the block dialog box.

2 Select the Visualization tab and click Plot to plot the frequency response
of the filter. This plots the magnitude of S,, as a function of frequency,
which represents the gain of the filter.



Model an LC Bandpass Filter

) untitled /LC Bandpass Pi =] b

File Edit View Insert Tools Desktop Window Help a
Ndde t[RATDEL-2|0E]| e
Z0= 50
1]

L T T

' ' ' ' ' ' '
S ) ) S — A A —— A —— [ —— P I, [ — —
v v v v v v v

—
o

T
'
'
'
'
'
'
'
'
v
'
'
'
'
'
'
'
-
'
'
'
'
'
'
'
'
-
'
'
'
'
'
'
'
'
-
'
'
'
'
'
'
'
'
-
'
'
'
'
'
'
'
'
a4
'
'
'
'
'
'
'
'
a4
'
'
'
'
'
]

Magnitude (decibels)

]
T
!
:
:
:
;
,
,

!
X
:
:
:
:
:
:
,
!
X
:
:
:
:
:
:
,
!
X
:
:
:
:
:
:
:
.
|
:
:
:
:
:
:
:
.
|
:
:
:
:
:
:
:
!
)
:
:
:
:
:
:
:
!
)
:
:
:
:
:
:

T | - RN SRRy PO OO PROLY SUPROLPROPROLRY SRR PRI SPUpIPIOPOIRY S _

s | | | i i | |

Filter Gain

Note The physical blocks only model a band of frequencies around the
center frequency of the physical subsystem. You must choose the sample
time and center frequency such that all important frequency characteristics
of your physical subsystem fall in this band of frequencies. The plot shows
the frequency response of the filter for the portion of the RF spectrum that
the physical blocks model. In this example, the physical blocks model a
500-MHz band centered at 700 MHz, as defined by the Input Port block.

3 In the model window, select Simulation > Start to run the simulation.
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Analyze the Simulation Results

In this part of the example, you analyze the results of the simulation. This
section contains the following topics:

¢ “Compare the Input and Output Signals of the RF Filter” on page 3-22
¢ “Plot Model Parameters of the Filter Subsystem” on page 3-24

Compare the Input and Output Signals of the RF Filter

You can view the source signal and the filtered signal in the Spectrum Scope
windows while the model is running. These windows appear automatically
when you start the simulation.

The Spectrum Scope blocks display the signals at the shifted
(baseband-equivalent) frequencies, not at the selected passband frequencies.
You can relabel the x-axes of the Spectrum Scope windows to display the
passband signal by entering the Center frequency parameter value of
700e6 (from the Input Port block) for the Frequency display offset (Hz)
parameter in the Axis Properties tab of the Spectrum Scope block dialog
boxes. For more information on complex-baseband modeling, see “Create a
Complex Baseband-Equivalent Model”.

The Spectrum Scope blocks display power spectral density normalized to unit
sampling frequency. To display power per channel, insert a Gain block with
the Gain parameter set to 1/sqrt (N) before each Spectrum Scope block. N is
the number of channels. The Gain block is in the Simulink > Commonly
Used Blocks library.

In this example, N is 128 (the value of the Samples per frame parameter of
the Sine Wave block, 128).

Note SimRF Equivalent Baseband signals represent amplitudes, not
voltages. This means that in the product, power is defined as:

Power (inwatts)=[ Amplitude (involts/ sqrt(ohm))]2
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The following plot shows the RF filter input signal you specified in the Sine
Wave block.
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The next plot shows the filtered signal. Notice the RF filter does not attenuate
the signal at the center frequency.
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Plot Model Parameters of the Filter Subsystem

After you simulate an RF model, you can evaluate the behavior of the physical
subsystem by plotting the network parameters of the Output Port block.

Note When you plot information about a physical subsystem, the plot
displays the actual frequency response of the subsystem at the selected
passband (i.e. the response at the unshifted frequencies), not the response at
the shifted frequencies.

To understand the frequency response of the filter, examine the S-parameters
as a function of frequency for the RF filter subsystem on a composite plot.

1 Open the dialog box of the Output Port block by double-clicking the block.

2 Select the Visualization tab, and click Plot.
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The composite plot, shown in the following figure, contains four separate
plots in one figure. For the Output Port block, the composite plot shows the
following as a function of frequency (counterclockwise from the upper-left

plot):
¢ An X-Y plane plot of the magnitude of the filter gain, S,,;, in decibels.

¢ An X-Y plane plot of the phase of the filter gain, S,,, in degrees.

e A 7Z Smith chart showing the real and imaginary parts of the filter
reflection coefficient, S,;.

® A Polar plane plot showing the magnitude and phase of the filter reflection
coefficient, S,;.

Note In this example, the response of the filter subsystem is the same as the
response of the filter block because the subsystem contains only a filter block.
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X-Y Plot,
Magnitude of S21

X-Y Plot,
Phase of S21
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